DIMO FAQ logo
DIMO FAQ logo

All articles

Will you support cars older than 2008 with the DIMO Macaron?Updated 8 months ago

The DIMO Macaron is compatible with vehicles from 2008 and newer, just like the DIMO AutoPi.

We continue to work on making older vehicles compatible.

Was this article helpful?
Yes
No